vn.py官网
开源量化社区
Member
avatar
加入于:
帖子: 26
声望: 2

Linux下安装vn.py总会有些小错误或警告,尤其是ta_lib直接安装有问题,且没有现成的whl文件可以下载。这里我首先想办法解决了ta_lib安装问题,然后再按文档里ubuntu的里vnpy安装方法,安装成功。
一、安装ta_lib
到这个网址下载ta_lib的一个c语言库 http://ta-lib.org/hdr_dw.html
然后解压缩安装
$ untar and cd
$ ./configure --prefix=/usr
$ make
$ sudo make install
二、上一步完成后,可以直接pip install ta_lib,安装会成功不会再出错。
三、再安装vn.py官网的文档,用anaconda建立python3.7的虚拟环境并进入环境,再进入vnpy的解压缩根目录,bash install.sh安装成功。在虚拟环境的终端中python run.py一切正常,祝您好运。

Administrator
avatar
加入于:
帖子: 4871
声望: 283

感谢分享,给你加个精华

Member
avatar
加入于:
帖子: 26
声望: 2

连接CTP过程中会产生locale错误:
terminate called after throwing an instance of 'std::runtime_error'
what(): locale::facet::_S_create_c_locale name not valid
Aborted
通过 sudo dpkg-reconfigure locales,然后添加zh_CN.GB18030选项框,可以解决这个问题。

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3

沪公网安备 31011502017034号