vn.py官网
开源量化社区
Member
avatar
加入于:
帖子: 1
声望: 0

按置顶那个教程搞不赢

  1. 清华Conda镜像最近不太稳定,导致python.app下载失败【另外,python3.43以后OSX就不需要pythonw了,其实可以不安装python.app】
  2. Mac OS最新版Big Sur 11.2.3 和 requirement.txt 里面要求的PyQt5版本5.14.1不兼容,必须升级到最新的5.15.4。
  3. pip装psycopg2报错找不到“pg-config”可执行文件,需要先brew install postgresql
  4. 看官方的安装脚本,ta-lib-0.4.0的可执行文件是必须的,置顶教程没提,安全起见还是brew install ta-lib安装一下。
  5. requirement.txt 文件里面的 wmi 库仅限windows使用,mac下安装直接删掉或注释这行。
  6. run.py文件一共要注销掉两行
# 7行
from vnpy.gateway.ctp import CtpGateway
# 76行
main_engine.add_gateway(CtpGateway)

大概就是这么回事,详细步骤的话,大家有兴趣留言给我补一下,没人感兴趣我就不补了

Member
avatar
加入于:
帖子: 1
声望: 1

大佬,求助。我这边运行报错:qt.qpa.plugin: Could not find the Qt platform plugin "cocoa" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Member
avatar
加入于:
帖子: 1
声望: 0

已经安装好VN.trader,感谢大佬!

Member
avatar
加入于:
帖子: 470
声望: 20

林峰9322981ba17e4ca1 wrote:

大佬,求助。我这边运行报错:qt.qpa.plugin: Could not find the Qt platform plugin "cocoa" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

请运行vnpy/examples/no_ui/下的run.py

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3

沪公网安备 31011502017034号