vn.py官网
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 55
声望: 0

按照说明安装的最新版Anaconda,不过改版本是Python 3.9。发现 quikfix 和 TA_Lib 安装不了,即使下载到本地也是安装不了。基本上每次更新重新安装都是很多的库版本对不上或者有冲突。每次升级安装说明能否说明需要在哪个python版本下面去安装。

(base) E:\code\vnpy-master>python -m pip install https://pip.vnpy.com/colletion/quikfix-1.15.1-cp39-cp39m-win_amd64.whl
ERROR: quikfix-1.15.1-cp39-cp39m-win_amd64.whl is not a supported wheel on this platform.

(base) E:\code\vnpy-master>python -m pip install https://pip.vnpy.com/colletion/TA_Lib-0.4.17-cp37-cp37m-win_amd64.whl
ERROR: TA_Lib-0.4.17-cp37-cp37m-win_amd64.whl is not a supported wheel on this platform.

Member
avatar
加入于:
帖子: 343
声望: 25

请问是什么系统,linux系统下载quikfix需要自己编译,talib你的文件是支持python3.7的,请换成对应的版本。

Member
avatar
加入于:
帖子: 123
声望: 13

看路径,是windows系统。

你可以去anaconda版本库中找一下py3.7的来做。或者呢,去找一quickfix、tablib的39版本。

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3

沪公网安备 31011502017034号