vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 48
声望: 0

经过几天的折腾,终于可以在ubuntu图形化界面上VNC运行vnpy了,但是在跑vnpy-master\examples\candle_chart\run.py程序时候,出现了错误,这个程序在windows下运行得很顺利,在vnc下的ubuntu图形化界面却不成功。提示如下:

description

description

根据提示,好像是vnc下的xserver不支持 bottom这个属性,请问版主,你们在ubuntu图形化界面上做过测试了吗?这个问题现在怎么解决?后来发现在VNPY主界面上,只要订阅后,选择图表,应该出来行情的K线图,结果都是同样的错误,请版主验证一下。

我好不容易终于在ubuntu图形化界面上跑起来了vnpy,目前就差这一个坑了,希望能获得解决!

Member
avatar
加入于:
帖子: 48
声望: 0

在linux上的VNC图形化界面上画图,特别是下图有 volume的附图情况下,vnpy都会出错。请版主验证一下。

Member
avatar
加入于:
帖子: 1661
声望: 112

可参考此帖看看

Member
avatar
加入于:
帖子: 48
声望: 0

我查看了一下,我的pyqtgraph是0.11版本,你们的系统要求pyqtgraph==0.10.0,我卸载了pyqtgraph,然后重新指定安装pyqtgraph==0.10.0,这下可以了!

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3

沪公网安备 31011502017034号