vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 48
声望: 0

下午在腾讯云上租用了一台2核4G云服务器,最开始安装的是windows2012数据中心64版本,安装好vnpy后,双击后出现错误提示,好像是pyqt的问题,无法运行。看了一些帖子,说是新版本的vnpy不支持windows2012版本,推荐使用windows2019版本,我又重新安装了windows2019数据中心64位版本,再重装了vnpy,这下安装好双击后,没有任何反应,直接运行里面的python程序,也是不能运行。怎么回事?管理员能否帮忙解决一下?

Member
avatar
加入于:
帖子: 1761
声望: 117

不知道你的报错是否和这个帖子一样,如果是,可以参考一下

Member
avatar
加入于:
帖子: 48
声望: 0

我最开始的时候是在windows2012数据中心64位上安装VNPY的,安装成功后,双击vnpy,出现的就是那个错误,后来我将那个文件名改了,双击vnpy,没有任何反应,然后我查了帖子说是不支持windows2012,所以我重装了服务器,改成了windows2019数据中心64位,但是安装成功后,双击vnpy,却还是没有任何反应,都是新机器,第一次安装,不知道问题出在哪里了?

Member
avatar
加入于:
帖子: 1761
声望: 117

你可以像帖子里建议的到文件夹中 vnstudio中\Lib\site-packages\PyQt5\Qt\bin\
将Qt5Bluetooth.dll 重命名为 Qt5Bluetooth.dll1试试看看

Member
avatar
加入于:
帖子: 48
声望: 0

这招在windows2012环境下用过了,虽然没有提示那个错误提示了,但是双击后变成没有任何反应了。后来我在windows2019下也试着改了文件名,仍然还是双击没有任何反应。

Member
avatar
加入于:
帖子: 1761
声望: 117

那请安装vcredist 2015-2019试试看

Member
avatar
加入于:
帖子: 48
声望: 0

终于解决了!

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3

沪公网安备 31011502017034号