vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 2
声望: 0

运行python -m vnstation, 提示:
qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_ciphersuites
qt.network.ssl: QSslSocket: cannot resolve SSL_set_psk_use_session_callback
qt.network.ssl: QSslSocket: cannot resolve SSL_SESSION_is_resumable
qt.network.ssl: QSslSocket: OpenSSL >= 1.1.1 is required; OpenSSL 1.1.0i 14 Aug 2018 was found instead
判断和SSL有关,百度“qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_ciphersuites” 找到这一篇:
https://www.cnblogs.com/fancyop/p/qt_ssl_q.html

解决方案:

1.下载并安装Win64 OpenSSL v1.1.1d Light
description
文件下载地址:http://slproweb.com/products/Win32OpenSSL.html

  1. 安装好后在安装目录找到 libcrypto-1_1-x64.dll 和 libssl-1_1-x64.dll 两个文件 ,然后粘贴并覆盖 vnstudio 目录下的同名文件。
    description

  2. 重启vnstation 登录,问题完美解决。

Member
avatar
加入于:
帖子: 8
声望: 1

我照这方法做了,没有解决,反而多了个新的错误。。
description

Member
avatar
加入于:
帖子: 733
声望: 35

这是PyQt新版本兼容性的问题,请使用最新的2.1.4版本安装包即可,已经降级到了之前的版本。

Member
avatar
加入于:
帖子: 4
声望: 1

将要 wrote:

我照这方法做了,没有解决,反而多了个新的错误。。
description

同出现这个问题,请问下最后怎么解决的

Member
avatar
加入于:
帖子: 733
声望: 35

solardata wrote:

将要 wrote:

我照这方法做了,没有解决,反而多了个新的错误。。
description

同出现这个问题,请问下最后怎么解决的

请问你现在是用的2.1.4吗?

Member
avatar
加入于:
帖子: 4
声望: 1

xiaohe wrote:

solardata wrote:

将要 wrote:

我照这方法做了,没有解决,反而多了个新的错误。。
description

是的,最新的2.1.4
同出现这个问题,请问下最后怎么解决的

请问你现在是用的2.1.4吗?

Member
avatar
加入于:
帖子: 5
声望: 0

我用的是2.1.4

description

Member
avatar
加入于:
帖子: 5
声望: 0

按照上面的方法,替换了,也这样了

Member
avatar
加入于:
帖子: 5
声望: 0

我知道问题在哪了,
1.替换路径的问题

  1. C:\Program Files\OpenSSL-Win64\bin,里面的x64.dll的两个文件,
  2. 替换到C:\vnstudio
Member
avatar
加入于:
帖子: 1
声望: 0

2.1.14有问题,改装的2.0.6能打开了,链接:https://www.vnpy.com/docs/cn/install.html#windows
description

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3