vn.py官网
开源量化社区
Member
avatar
加入于:
帖子: 4
声望: 0

从github上下载的master版的vnpy,具体是什么版本不是很清楚。
运行里面no_ui的run.py, 报from .vnctpmd import MdApi错误,尝试在该文件夹内import也是报错。
我的python是3.8版本,不知道是不是这个动态库封的不支持这个版本的?

Administrator
avatar
加入于:
帖子: 4749
声望: 278

请问你的操作系统是?以及提供下完整报错的cmd截图吧

Member
avatar
加入于:
帖子: 4
声望: 0

用Python的交易员 wrote:

请问你的操作系统是?以及提供下完整报错的cmd截图吧
操作系统是win10 64位,python是3.8
报错截图:

description
我也尝试直接在该动态库目录下import,还是不行。不知道什么原因

Administrator
avatar
加入于:
帖子: 4749
声望: 278

请检查两个点:

  1. 必须是64位的Python
  2. 如果还不行就要自己编译下ctp接口了
Member
avatar
加入于:
帖子: 4
声望: 0

python是64位的....那我去学习下怎么编译CTP接口....

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3

沪公网安备 31011502017034号