VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 19
声望: 0

04:00.3 交易服务器连接断开,原因4097 CTPTEST
03:56.3 交易服务器连接断开,原因4097 CTPTEST
03:52.7 交易服务器连接断开,原因4097 CTPTEST
03:48.0 交易服务器连接断开,原因4097 CTPTEST
03:44.0 交易服务器连接断开,原因4097 CTPTEST
03:40.0 交易服务器连接断开,原因4097 CTPTEST
03:36.0 交易服务器连接断开,原因4097 CTPTEST
03:35.5 行情接口报错,代码:4040,信息:CTP:API Front shake hand err :version err CTPTEST
03:35.3 行情服务器连接断开,原因4097 CTPTEST

Member
avatar
加入于:
帖子: 4774
声望: 289

api版本不对,期货公司的测试api版本是?

Member
avatar
加入于:
帖子: 19
声望: 0

xiaohe wrote:

api版本不对,期货公司的测试api版本是?
6.6.1版本的,我向他们要来了dll,替换了以后还是报相同的错误。

Member
avatar
加入于:
帖子: 19
声望: 0

确认 dll已经更换了,如果没有这2个dll,station报错然后就死机了。

Member
avatar
加入于:
帖子: 19
声望: 0

期货公司又发来一个6.3.19版本,换了dll以后,行情服务器不报错,只报错:
交易服务器连接断开,原因4097 CTPTEST

Member
avatar
加入于:
帖子: 4774
声望: 289

如果用6.3.19的话,需要把vnpy_ctptest降级到6.5.1.5然后再替换dll,注意测试前telnet一下交易地址/行情地址看看服务器关了没

Member
avatar
加入于:
帖子: 19
声望: 0

xiaohe wrote:

如果用6.3.19的话,需要把vnpy_ctptest降级到6.5.1.5然后再替换dll,注意测试前telnet一下交易地址/行情地址看看服务器关了没

请问如何把vnpy_ctptest降级到6.5.1.5,谢谢。

Member
avatar
加入于:
帖子: 19
声望: 0

费了好多口舌,终于要到了期货公司的api准确版本

description

到github上查了一下,2.6版本的api正好是这个版本,下载2.6版本安装,结果3.4版本的竟然卸载不了,真奇怪。先安装2.6版本的试试。

Member
avatar
加入于:
帖子: 19
声望: 0

6.3.13

CTP穿透式柜台的仿真测试版本,也是CTPTEST接口中使用的API版本,所有客户的仿真接入认证测试都必须使用该版本!主要因为该版API采集客户的信息是没有加密的,期货公司可以在后台查看来进行认证工作。

6.3.15

CTP穿透式柜台的实盘交易版本,也是CTP接口中使用的API版本,完成仿真接入测试后,必须使用该版本才能连接实盘交易的CTP柜台。该版本的采集信息是安全加密的,期货公司的IT用后台系统也看不到。

因此,2种可能性:
1、估计测试API都要使用6.3.13的版本才可以,我估计2.6版本不一定可以,不行再降版本了。
2、测试也要用6.3.15版本的实盘才行。

Member
avatar
加入于:
帖子: 4774
声望: 289

小波 wrote:

xiaohe wrote:

如果用6.3.19的话,需要把vnpy_ctptest降级到6.5.1.5然后再替换dll,注意测试前telnet一下交易地址/行情地址看看服务器关了没

请问如何把vnpy_ctptest降级到6.5.1.5,谢谢。
先pip uninstall vnpy_ctptest卸载再pip install vnpy_ctptest==6.5.1.5就行了

Member
avatar
加入于:
帖子: 19
声望: 0

安装2.6版本后,启动就闪一下不见了。把3.4版本的环境变量删了,还是不行,卸载了重新装一遍。

Member
avatar
加入于:
帖子: 19
声望: 0

xiaohe wrote:

小波 wrote:

xiaohe wrote:

如果用6.3.19的话,需要把vnpy_ctptest降级到6.5.1.5然后再替换dll,注意测试前telnet一下交易地址/行情地址看看服务器关了没

请问如何把vnpy_ctptest降级到6.5.1.5,谢谢。
先pip uninstall vnpy_ctptest卸载再pip install vnpy_ctptest==6.5.1.5就行了

谢谢,等我装2.6试试先。

Member
avatar
加入于:
帖子: 19
声望: 0

2.6安装完了还是闪退。

Member
avatar
加入于:
帖子: 19
声望: 0

还是安装3.4,到上期技术网站下载6.3.16版本的api,把dll替换掉就行了。

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】