VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 8
声望: 0

packages\jqdatasdk\api.py:34: PanelObsoleteWarning: 当前环境 pandas 版本高于 0.25,get_price 与 get_fundamentals_continuously 接口的 panel 参数将固定为 False(0.25 及以上版本的 pandas 不再支持 panel,如使用该数据结构和相关函数请注意修改)
warnings.warn(PandasChecker.VERSION_NOTICE_MESSAGE, PanelObsoleteWarning)

Member
avatar
加入于:
帖子: 8
声望: 0

版本是最新的3.3版,回测时似乎没什么问题,但是在模拟盘时就不行,请各位大佬指导一下

Member
avatar
加入于:
帖子: 3469
声望: 228

veighna_station没有自带jqdata,这个报错和veighna_station无关了。而且这只是个warning不是error,如果有用到提示里的函数可以自己对pandas版本进行调整了,但是具体会不会影响到station的运行需要自行测试了

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】