VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 3
声望: 0

电脑本身安装了anaconda3,python=3.9 手动安装了vnpy的zip包,最后启动run.py时,报了如下错误,是不是因为spyder和pyside6冲突引起的。求解

提示如下:

Found invalid metadata in lib D:/anaconda3/Library/plugins/platforms/qdirect2d.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/platforms/qminimal.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/platforms/qoffscreen.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/platforms/qwindows.dll: Invalid metadata version
D:\anaconda3\lib\site-packages\qtpy__init__.py:201: RuntimeWarning: Selected binding "pyside6" could not be found, using "pyqt5"
warnings.warn('Selected binding "{}" could not be found, '
No QCoreApplication instance found. Application patches not applied. You have to call loadstylesheet function after instantiation of QApplication to take effect.
Faile to import cython option pricing model, please rebuild with cython in cmd.
找不到数据服务驱动vnpy
,使用默认的RQData数据服务

Found invalid metadata in lib D:/anaconda3/Library/plugins/platforms/qdirect2d.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/platforms/qminimal.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/platforms/qoffscreen.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/platforms/qwindows.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/iconengines/qsvgicon.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qgif.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qicns.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qico.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qjpeg.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qsvg.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qtga.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qtiff.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qwbmp.dll: Invalid metadata version
Found invalid metadata in lib D:/anaconda3/Library/plugins/imageformats/qwebp.dll: Invalid metadata version

Member
avatar
加入于:
帖子: 3593
声望: 234

可以升级一下qtpy试试看,其他输出不影响运行的

Member
avatar
加入于:
帖子: 644
声望: 34

推荐直接用VeighNa Studio吧,手动装要自己管理解决很多Python包的冲突

Member
avatar
加入于:
帖子: 3
声望: 0

MTF wrote:

推荐直接用VeighNa Studio吧,手动装要自己管理解决很多Python包的冲突

Member
avatar
加入于:
帖子: 3
声望: 0

感谢,我回去试下直接安装 用pycharm编译吧

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】