VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 4
声望: 0

新换了台电脑,jupyter notebook用不了,无法连接ipyKernel,错误信息:Bad file descriptor (C:\projects\libzmq\src\epoll.cpp:100)

description

description

上网去查,说是pyzmq的版本太高导致的,需要从23版本降到19.0.2版本。结果用pip安装低版本pyzmq时,提示:fatal error LNK1181: 无法打开输入文件“libzmq.cp310-win_amd64.lib”

description

自己下载pyzmq的whl安装,提示: pyzmq-19.0.2-cp39-cp39-win_amd64.whl is not a supported wheel on this platform. 貌似是跟python3.10不兼容

description

我的另一台电脑python3.10+pyzmq23是可以用jupyter的,求大神们帮忙看看,在不重装系统的前提下该怎么解决,谢谢!

Member
avatar
加入于:
帖子: 716
声望: 55

试试重装jupyter notebook或者装jupyterlab

Member
avatar
加入于:
帖子: 4
声望: 0

郭易燔 wrote:

试试重装jupyter notebook或者装jupyterlab

没用啊,装了好几次了,感觉是操作系统的问题

Member
avatar
加入于:
帖子: 4
声望: 0

找到一个办法,把python降到3.9(卸载了veighna,用的anaconda,不会在veighna中直接降级python),然后用whl安装低版本pyzmq

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】