vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 5
声望: 0

description

如上图所示:
ubuntu18.04 desktop版本, 安装vnpy-2.0.7 成功,但运行./examples/vn_trader/run.py 失败,
win32api 模块应该是用在windows系统下的吧?
在ubuntu系统下如何运行vnpy的交易和回测的图形界面?
请教原因?

Member
avatar
加入于:
帖子: 16
声望: 1

linux系统下不支持win32api模块,需要将run.py中的da接口屏蔽掉,才能运行。

Member
avatar
加入于:
帖子: 5
声望: 0

谢谢,将run.py中的da接口屏蔽掉,可以运行了。

Member
avatar
加入于:
帖子: 7
声望: 0

windows也是出现这样的问题,解决方案
是不是把run.py
里面的那行代码 from vnpy.gateway.da import DaGateway
注释掉就可以了,
这样会影响后面软件的运行吗?

Member
avatar
加入于:
帖子: 20
声望: 3

你好 我也是这个版本 我装完运行run.py 出现qapp.exec() 报错的情况 另一种错误是no moduld named 'vnpy' 请问如何解决

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3