vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 50
声望: 0

vnpy2.0.6版本,运行run.py文件后,显示错误代码
description
这是为什么?

Member
avatar
加入于:
帖子: 50
声望: 0

但是2.0.4就没有报错,可以正常运行

Member
avatar
加入于:
帖子: 2
声望: 0

我也遇到同样的问题

description
我的也是2.0.6,应该怎么解决?

Member
avatar
加入于:
帖子: 50
声望: 0

我解决了,因为下载的python是32位的,你下一个64位的试试

Member
avatar
加入于:
帖子: 2
声望: 0

嘿,感谢楼上指导。果真是32位的问题。我换成64位解决了。

给后来者一个指引:
1。去官方下载一个64位的,以windows为例,名字python-3.7.4-amd64,记得先卸载旧的32位python,并将安装目录下的所有文件删除,被site-packages坑了一次。
2。运行vnpy根目录下的install.bat有时会安装失败,因为可能会超时,这个时候就得将requirements.txt里面的包一个个手动安装了:pip install xxxxx
dataclasses没装,因为我的是3.7的
3。如果遇到ta-lib的问题,去下载一个,并解压放到C盘根目录,如:C:\ta-lib
4。最后按官方所述,建一个run.py, 运行看看。

Administrator
avatar
加入于:
帖子: 1441
声望: 63

请直接用www.vnpy.com官网下的VNStudio最新版本,别再折腾各种安装了

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3