vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 6
声望: 0

请教一下,现在1.9.2-LTS版本,怎么连接的时候出现提示: 配置缺少字段,请检查的...

Administrator
avatar
加入于:
帖子: 1441
声望: 63

CTP的话需要加上appID和authCode

Member
avatar
加入于:
帖子: 6
声望: 0

已经加上了哦

Member
avatar
加入于:
帖子: 6
声望: 0

已经加上了,还有出现提示: 配置缺少字段 不会simnow 最近的修改吧

Administrator
avatar
加入于:
帖子: 1441
声望: 63

请贴下你的CTP_connect.json内容?账号密码用XXX代替好了,最简单的解决方案是升级用2.0.6了

Member
avatar
加入于:
帖子: 6
声望: 0

{
"brokerID": "9999",
"mdAddress": "tcp://218.202.237.33:10112",
"tdAddress": "tcp://218.202.237.33:10102",
"userID": "",
"password": "*
"
"appID": "simnow_client_test"
"authCode": "0000000000000000"
}

Administrator
avatar
加入于:
帖子: 1441
声望: 63

看着没什么问题啊,这是你放在run.py启动脚本目录,一般是examples/VnTrader,下的json文件吗?

实在搞不定就用2.0.6吧

Member
avatar
加入于:
帖子: 6
声望: 0

Anaconda2里边site-packages 的VNPY里边也修改了,另外examples/VnTrader,下的json文件也修改了 还是出现在这个提示: “配置缺少字段“
2.0.6版本有些功能,比1.9.2版本功能所没有的,比如价差、期权、风控模块...

Administrator
avatar
加入于:
帖子: 1441
声望: 63

整体是解决1.9.2为了保证历史兼容的遗留问题,目前期权和价差还没移植,其他模块都移植完全了。

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3