VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 14
声望: 1

ubuntu系统尝试了python3.6 3.7 以及 3.8
vnpy尝试2.2.0 2.3.0 以及 2.5.0版本
运行脚本时均出现以下报错
AttributeError: 'backports.zoneinfo.ZoneInfo' object has no attribute 'zone'

报错语句为:
from vnpy.trader.engine import MainEngine
from .setting import SETTINGS
"database.timezone": get_localzone().zone

求解答,谢谢!

Super Moderator
avatar
加入于:
帖子: 529
声望: 43

tzlocal在最新的版本里更改了python3.8以下版本支持的api,将tzlocal降级到2.1就可以解决

Member
avatar
加入于:
帖子: 15
声望: 1

降级安装: pip install tzlocal==2.1 -i http://pypi.douban.com/simple --trusted-host pypi.douban.com

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】