VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 6
声望: 0

用了 install.sh 安装之后报了

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
spyder 4.0.1 requires pyqt5<5.13; python_version >= "3", but you have pyqt5 5.14.1 which is incompatible.

尝试安装pip3 install pyqt5==5.12,结果报了

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
qscintilla 2.11.4 requires PyQt5-sip<13,>=12.7, but you have pyqt5-sip 4.19.19 which is incompatible.

尝试:pip3 install PyQt5-sip==12.8.1

结果

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
pyqt5 5.12 requires PyQt5_sip<4.20,>=4.19.14, but you have pyqt5-sip 12.8.1 which is incompatible.
Successfully installed PyQt5-sip-12.8.1

懵圈了

Member
avatar
加入于:
帖子: 4749
声望: 288

可以一键安装试试

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】