vn.py量化社区
By Traders, For Traders.
Member
加入于:
帖子: 29
声望: 0

我一直使用python3跑vnpy1.9版,之前在vnpy\api\ctp文件夹中有py3文件夹为python3编译ctp接口,请问刚更新的vnpy1.9版本有提供使用python3编译ctp接口的方法吗?

Member
加入于:
帖子: 115
声望: 29

@albert
问问用python3跑vnpy1.9修改地方多吗?
我有些策略引用库要用python3,不过实盘vnpy1.9;

Member
加入于:
帖子: 29
声望: 0

张国平 wrote:

@albert
问问用python3跑vnpy1.9修改地方多吗?
我有些策略引用库要用python3,不过实盘vnpy1.9;

不多,一点语法问题

Member
加入于:
帖子: 29
声望: 0

求回复

Administrator
avatar
加入于:
帖子: 3588
声望: 190

官方没有提供,你得自己改代码编译了

Member
avatar
加入于:
帖子: 5
声望: 0

我编译了python3.6 64位的,有需要可以发给你~

Member
avatar
加入于:
帖子: 15
声望: 0

iostream wrote:

我编译了python3.6 64位的,有需要可以发给你~

能不能发给我一份(379952189@qq.com), 同样是python3.6 64位, 一直报错(ImportError: DLL load failed: 找不到指定的模块。),感谢 !~

Member
avatar
加入于:
帖子: 9
声望: 0

求分享(329362855@qq.com)

Member
avatar
加入于:
帖子: 20
声望: 0

@iostream同求分享,1216505182@qq.com

Member
avatar
加入于:
帖子: 2
声望: 0

Evon wrote:

iostream wrote:

我编译了python3.6 64位的,有需要可以发给你~

能不能发给我一份(379952189@qq.com), 同样是python3.6 64位, 一直报错(ImportError: DLL load failed: 找不到指定的模块。),感谢 !~

你用64为的python3x版本 链接ctp 电脑里先要有vc程序运行环境
下载地址 http://go.microsoft.com/fwlink/?LinkId=691126

文件名 visualcppbuildtools_full.exe
Microsoft Visual C++ Build Tools (2015-2019)

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3