vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 5
声望: 0

在安装vnpy之前,电脑上已经安装了Anaconda。通过vnpy conda 2.01安装了vnpy之后,GUI可以正常打开运行,但是在Anaconda的spyder中运行import vnpy会报错找不到该库,请问这是什么原因?

Administrator
avatar
加入于:
帖子: 1908
声望: 85

因为你运行的Spyder对应的Python环境是之前的Anaconda,而你的vnpy并未安装到该环境中(而是位于VNConda中)

Member
avatar
加入于:
帖子: 5
声望: 0

好的,谢谢答主!
如果直接通过pip install vnpy来安装的时候,下载的版本好像是1.92
请问是否有别的方式可以在Anaconda中运行vnpy2吗?谢谢

Member
avatar
加入于:
帖子: 5
声望: 0

经测试,如下步骤安装:

  1. 清理python以及Anaconda
  2. 安装VNConda,
  3. cmd : pip install jupyter notebook
  4. 此时即可以正常通过VN Station打开jupyter,import vnpy可正常运行,版本2.0+
  5. 安装Anaconda,不要注册为系统默认python
    不过,通过这样的安装,暂无法在Anaconda的spyder中运行2.0+的vnpy
© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3