VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 6
声望: 0

ERROR: Could not find a version that satisfies the requirement rqdatac (from vnpy==2.1.6) (from versions: none)
ERROR: No matching distribution found for rqdatac (from vnpy==2.1.6)

Member
avatar
加入于:
帖子: 6
声望: 0

请问哪位大神来看看,这个文件pip install 中没有。 如何安装呢?

Member
avatar
加入于:
帖子: 4544
声望: 276

可参考https://www.vnpy.com/forum/topic/626-xiao-bai-ti-wen-rqdatac-zen-yao-an-zhuang
https://www.vnpy.com/forum/topic/1792-rqdatacan-zhuang

Member
avatar
加入于:
帖子: 6
声望: 0

好的。 谢谢。晚上回去试试。这个软件包是做什么的?

Member
avatar
加入于:
帖子: 4544
声望: 276

米筐

Member
avatar
加入于:
帖子: 6
声望: 0

执行命令: pip install https://pip.vnpy.com/colletion/rqdatac-2.1.0.tar.gz
还是报错。文件找不到。
报错信息如下:
ERROR: HTTP error 404 while getting https://pip.vnpy.com/colletion/rqdatac-2.1.0.tar.gz
ERROR: Could not install requirement https://pip.vnpy.com/colletion/rqdatac-2.1.0.tar.gz because of HTTP error 404 Client Error: Not Found for url: https://pip.vnpy.com/colletion/rqdatac-2.1.0.tar.gz for URL https://pip.vnpy.com/colletion/rqdatac-2.1.0.tar.gz

Member
avatar
加入于:
帖子: 4544
声望: 276

那就参照一下第一个帖子里的建议使用Github仓库里的install.bat脚本安装试试看吧

Member
avatar
加入于:
帖子: 6
声望: 0

重新下载并安装,运行install.bat
错误还在。
ERROR: Could not find a version that satisfies the requirement rqdatac (from -r requirements.txt (line 19)) (from versions: none)
ERROR: No matching distribution found for rqdatac (from -r requirements.txt (line 19))

Member
avatar
加入于:
帖子: 4544
声望: 276

https://pypi.org/project/rqdatac/2.9.3/
那可以试一下这个链接里的行不行,不行的话建议直接使用VNstation了

Member
avatar
加入于:
帖子: 6
声望: 0

进去找到一堆下载文件,看看都是for MAC/Linux/AMD win, 就是没有一般WIN的。 放弃。 VNstation就是 .exe 那个文件吗?

Member
avatar
加入于:
帖子: 4544
声望: 276

https://download.vnpy.com/vnstudio-2.1.6.exe

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】