VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 10
声望: 0

首先我之前用的3.0版。 但是在把MacOS 从Montery 升级到Ventura 之后 就不能用了。

于是我从github 下载vnpy 的mac 压缩包 解压后,用pycharm打开,自动进入vnpy-3.6.0虚拟环境。
然后运行了 bash install_osx.sh 之后 出现了这样的状况

description

我试着手动pip install 例如 pip install vnpy_ctastrategy 是可以安装的。

我想请问下,是我安装哪里出了问题呢?还是现在MacOS 就是要这样手动安装?

Member
avatar
加入于:
帖子: 1467
声望: 105

brad-pigg wrote:

首先我之前用的3.0版。 但是在把MacOS 从Montery 升级到Ventura 之后 就不能用了。

于是我从github 下载vnpy 的mac 压缩包 解压后,用pycharm打开,自动进入vnpy-3.6.0虚拟环境。
然后运行了 bash install_osx.sh 之后 出现了这样的状况

description

我试着手动pip install 例如 pip install vnpy_ctastrategy 是可以安装的。

我想请问下,是我安装哪里出了问题呢?还是现在MacOS 就是要这样手动安装?

目前都需要手动安装的

Member
avatar
加入于:
帖子: 10
声望: 0

MTF wrote:

目前都需要手动安装的

我手动安装vnpy_rqdata 之后跑run.py 出现了问题。安装的版本 是版2.9.56.1,跑的时候报错。

description

然后我试着pip install vnpy_rqdata==2.10.14 又出现报错

description

现在我无法使用cta_backtest的模块

Member
avatar
加入于:
帖子: 1467
声望: 105

brad-pigg wrote:

MTF wrote:

目前都需要手动安装的

我手动安装vnpy_rqdata 之后跑run.py 出现了问题。安装的版本 是版2.9.56.1,跑的时候报错。

description

然后我试着pip install vnpy_rqdata==2.10.14 又出现报错

description

现在我无法使用cta_backtest的模块

一起升级下vnpy_ctastreategy/vnpy_ctabacktester/vnpy_datamanger等模块

Member
avatar
加入于:
帖子: 10
声望: 0

MTF wrote:

一起升级下vnpy_ctastreategy/vnpy_ctabacktester/vnpy_datamanger等模块

你说的这些模块全部已经是最新版本了。vnpy_rqdata现在的问题是我装不了最新版本会报错,如上一条里的图。

Member
avatar
加入于:
帖子: 1467
声望: 105

参考公众号里的Mac安装教程操作吧

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】