VeighNa量化社区
你的开源社区量化交易平台
Member
加入于:
帖子: 3
声望: 0

在mac非M1系统上安装vnpy_tts时报错:

building 'vnpy_tts.api.vnttstd' extension
clang -Wno-unused-result -Wsign-compare -Wunreachable-code -DNDEBUG -g -fwrapv -O2 -Wall -fPIC -O2 -isystem /opt/anaconda3/envs/py310/include -fPIC -O2 -isystem /opt/anaconda3/envs/py310/include -stdlib=libc++ -Ivnpy_tts/api/include -Ivnpy_tts/api/vntts -I/opt/anaconda3/envs/py310/include/python3.10 -c vnpy_tts/api/vntts/vnttstd/vnttstd.cpp -o build/temp.macosx-10.9-x86_64-3.10/vnpy_tts/api/vntts/vnttstd/vnttstd.o -O2 -MT
clang: error: argument to '-MT' is missing (expected 1 value)
error: command '/usr/bin/clang' failed with exit code 1

查看tts官方介绍说支持mac系统:

目前已提供CTPAPI全部在用的四个版本API,提供Win32、Win64、Linux64、Mac64及FreeBSD64共5个平台40个动态库。

请问有没有其他办法在mac上安装vnpy_tts?谢谢大佬!

Member
avatar
加入于:
帖子: 449
声望: 23

vnpy_tts目前没有支持MAC的

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】