VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 3
声望: 0

win10 64位,anaconda3环境安装vnpy遇上问题:
Building wheels for collected packages: ta-lib
Building wheel for ta-lib (setup.py) ... error
error: subprocess-exited-with-error

× python setup.py bdist_wheel did not run successfully.
│ exit code: 1
╰─> [520 lines of output]

n-amd64-3.8\Release\talib_ta_lib.obj
_ta_lib.c
d:\programdata\anaconda3\lib\site-packages\numpy\core\include\numpy\npy_1_7_deprecated_api.h(14) : Warning Msg: Using deprecated NumPy API, disable it with #define NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION
talib_ta_lib.c(6977): warning $146: 一元负运算符应用于无符号类型,结果仍为无符号类型
talib_ta_lib.c(6982): warning $146: 一元负运算符应用于无符号类型,结果仍为无符号类型
talib_ta_lib.c(7172): warning $146: 一元负运算符应用于无符号类型,结果仍为无符号类型
talib_ta_lib.c(7354): warning $146: 一元负运算符应用于无符号类型,结果仍为无符号类型

请问各位大神是什么原因啊,如何解决

Member
avatar
加入于:
帖子: 449
声望: 23

pip无法直接安装talib,用conda命令装吧

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】