VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 3
声望: 0

Traceback (most recent call last):
File "/Users/tim/Downloads/vnpy-3.0.0/run.py", line 28, in <module>
main()
File "/Users/tim/Downloads/vnpy-3.0.0/run.py", line 12, in main
qapp = create_qapp()
File "/Users/tim/Downloads/vnpy-3.0.0/vnpy/trader/ui/qt.py", line 28, in create_qapp
qapp.setStyleSheet(qdarkstyle.load_stylesheet(qt_api="pyside6"))
File "/Users/tim/opt/anaconda3/python.app/Contents/lib/python3.8/site-packages/qdarkstyle/init.py", line 370, in load_stylesheet
stylesheet = _load_stylesheet(qt_api=qt_api, palette=palette)
File "/Users/tim/opt/anaconda3/python.app/Contents/lib/python3.8/site-packages/qdarkstyle/init.py", line 244, in _load_stylesheet
from qtpy.QtCore import QCoreApplication, QFile, QTextStream
File "/Users/tim/opt/anaconda3/python.app/Contents/lib/python3.8/site-packages/qtpy/init.py", line 111, in <module>
assert API in (PYQT5_API + PYQT4_API + PYSIDE_API + PYSIDE2_API)
AssertionError

安装的VeighNa3.0,python版本是3.8

Member
avatar
加入于:
帖子: 716
声望: 55

请问安装的时候是否有报错,还有mac是m1芯片的么

Member
avatar
加入于:
帖子: 3
声望: 0

郭易燔 wrote:

请问安装的时候是否有报错,还有mac是m1芯片的么
安装的时候就说有哪个库没有装,装完了运行run.py就报错了。mac是6,7年前的macbook air,系统是mojave 10.14.6

Member
avatar
加入于:
帖子: 716
声望: 55

麻烦再重新装一下,看一下是哪个库没有装好,看报错好像是qt或者pyside6的问题

Member
avatar
加入于:
帖子: 3
声望: 0

郭易燔 wrote:

麻烦再重新装一下,看一下是哪个库没有装好,看报错好像是qt或者pyside6的问题
我把anaconda3卸载了以后重装也还是出现这个报错

Member
avatar
加入于:
帖子: 716
声望: 55

你之前说安装时有报哪个库没找到,那pyside6有安装成功么

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】