VeighNa量化社区
你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 12
声望: 0

如题

账户和密码都是登陆wind时候填过的,肯定没错,但是vnpy配置提交之后,就是没有办法连接成功,使用文档里面也没有详细的说明,求指教,谢谢

Member
avatar
加入于:
帖子: 647
声望: 35

命令行启动Python,然后import WindPy as w看看有没有报错,如果有的话就需要修复下Wind数据平台的Python插件

Member
avatar
加入于:
帖子: 12
声望: 0

MTF wrote:

命令行启动Python,然后import WindPy as w看看有没有报错,如果有的话就需要修复下Wind数据平台的Python插件
试过了,没有问题的,自己每天都在用wind 的python接口

Member
avatar
加入于:
帖子: 12
声望: 0

在全局配置的时候,
datafeed.name :wind
datafeed.username:填的wind登录账号
然后填登录密码

不知道这样是不是有问题?

Member
avatar
加入于:
帖子: 3594
声望: 234

vnpy_wind接口连接的是本地电脑运行着的Wind终端(而非远程的Wind服务器),因此在运行前必须先启动并登录Wind终端,在使用过程中也必须保持程序开启不能关闭。请问你有一直开着吗?

Member
avatar
加入于:
帖子: 12
声望: 0

是开着的,一直在看行情

Member
avatar
加入于:
帖子: 716
声望: 55

在命令行使用python -m vnstation启动界面,然后尝试下载数据,看一下底层有没有报错。

Member
avatar
加入于:
帖子: 12
声望: 0

郭易燔 wrote:

在命令行使用python -m vnstation启动界面,然后尝试下载数据,看一下底层有没有报错。
(VN Studio) C:\vnstudio>python -m vnstation
qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_ciphersuites
qt.network.ssl: QSslSocket: cannot resolve SSL_set_psk_use_session_callback
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_set_psk_use_session_callback
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_set_psk_use_session_callback
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_set_psk_use_session_callback
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_set_psk_use_session_callback
找不到数据服务驱动vnpy_wind,使用默认的RQData数据服务

说是找不到vnpy_wind,奇怪,但是我之前pip instal vnpy_wind,说是成功了啊,还需要如何设置一下吗?

Member
avatar
加入于:
帖子: 12
声望: 0

(VN Studio) C:\vnstudio>pip install vnpy_wind
Requirement already satisfied: vnpy_wind in c:\vnstudio\lib\site-packages (1.0.1)
Requirement already satisfied: importlib_metadata in c:\vnstudio\lib\site-packages (from vnpy_wind) (4.10.0)
Requirement already satisfied: typing-extensions>=3.6.4; python_version < "3.8" in c:\vnstudio\lib\site-packages (from importlib_metadata->vnpy_wind) (4.0.1)
Requirement already satisfied: zipp>=0.5 in c:\vnstudio\lib\site-packages (from importlib_metadata->vnpy_wind) (3.6.0)
You are using pip version 19.0.3, however version 22.0.4 is available.

确认了一下,的确是安装过vnpy_wind的
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

Member
avatar
加入于:
帖子: 3594
声望: 234

那可以pip list看一下你vnpy_wind是不是和别的vnpy的包装在同一个环境里

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】