vn.py官网
Veighna量化社区 | 你的开源社区量化交易平台
Member
avatar
加入于:
帖子: 3
声望: 0

云服务器成功安装了vnstudio,利用run.py脚本直接启动vn_trader报错、无法打开,采用python - m vnstation登陆后、在可以正常启动vn_trader。
报错信息如下:

PS C:\Trader_1> python run.py
Traceback (most recent call last):
File "run.py", line 4, in <module>
from vnpy.trader.engine import MainEngine
File "C:\vnstudio\lib\site-packages\vnpy\trader\engine.py", line 45, in <module>
from .setting import SETTINGS
File "C:\vnstudio\lib\site-packages\vnpy\trader\setting.py", line 9, in <module>
from .utility import load_json
File "C:\vnstudio\lib\site-packages\vnpy\trader\utility.py", line 15, in <module>
import talib
File "C:\vnstudio\lib\site-packages\talib__init.py", line 43, in <module>
from ._ta_lib import (
File "_abstract.pxi", line 34, in init talib._ta_lib
File "C:\vnstudio\lib\site-packages\pandas\
init.py", line 55, in <module>
from pandas.core.api import (
File "C:\vnstudio\lib\site-packages\pandas\core\api.py", line 29, in <module>
from pandas.core.groupby import Grouper, NamedAgg
File "C:\vnstudio\lib\site-packages\pandas\core\groupby\
init__.py", line 1, in <module>
from pandas.core.groupby.generic import DataFrameGroupBy, NamedAgg, SeriesGroupBy
File "C:\vnstudio\lib\site-packages\pandas\core\groupby\generic.py", line 60, in <module>
from pandas.core.frame import DataFrame
File "C:\vnstudio\lib\site-packages\pandas\core\frame.py", line 124, in <module>
from pandas.core.series import Series
File "C:\vnstudio\lib\site-packages\pandas\core\series.py", line 122, in <module>
class Series(base.IndexOpsMixin, generic.NDFrame):
File "C:\vnstudio\lib\site-packages\pandas\core\series.py", line 4562, in Series
plot = CachedAccessor("plot", pandas.plotting.PlotAccessor)
AttributeError: module 'pandas' has no attribute 'plotting'
PS C:\Trader_1> PS C:\Trader_1> python run.py

Member
avatar
加入于:
帖子: 106
声望: 8

请问你的pandas的版本是?

Member
avatar
加入于:
帖子: 3
声望: 0

看了一下,pandas1.0.3版本的,是pandas版本的问题吗?我是直接用vnstudio安装文件一键安装的,安装也是成功的

Member
avatar
加入于:
帖子: 2875
声望: 200

可以升级到1.3.3试试

Member
avatar
加入于:
帖子: 106
声望: 8

或者试试 pip install plotting试试

Member
avatar
加入于:
帖子: 3
声望: 0

更新到1.3.3后,问题解决,谢谢!
但是在成功更新pandas到1.3.3的同时,提示了如下错误,可能是与vnpy要求的pandas版本不符,是否可以忽略?
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
vnpy-arctic 1.0.1 requires pandas<=1.0.3, but you have pandas 1.3.3 which is incompatible.

Member
avatar
加入于:
帖子: 2875
声望: 200

如果不用arctic就可以忽略

© 2015-2022 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3

沪公网安备 31011502017034号

【用户协议】
【隐私政策】
【免责条款】