vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 1
声望: 0

配置:本机大环境是Ubuntu16.04,通过docker拉取并使用了github上ubuntu-18.04 + novnc + vnpy-1.9.1的镜像(https://github.com/vnpy/vnpy/wiki/vnpy-1.9.1%E7%9A%84docker%E9%95%9C%E5%83%8F%E7%9A%84%E4%BD%BF%E7%94%A8%E4%B8%8E%E5%88%B6%E4%BD%9C),由localhost novnc访问。

问题描述:参考入门教程更改了/example/VnTrader下的CTP_connect.json文档后,brokerID目前是9999,simnow的四组服务器都尝试过
第一组:Trade Front:180.168.146.187:10100,Market Front:180.168.146.187:10110;【电信】
第二组:Trade Front:180.168.146.187:10101,Market Front:180.168.146.187:10111;【电信】
第三组:Trade Front: 218.202.237.33 :10102,Market Front:218.202.237.33 :10112;【移动】
7*24小时环境:
第一组:Trade Front: 180.168.146.187:10130,Market Front:180.168.146.187:10131;【电信】

mdAddress和tdAddress也没有写反,userID按照说明使用的是brokerID,但conda_python run.py后连接CTP服务器,无论是行情服务器还是交易服务器都一直不断显示连接成功和断开,间隔1秒,不能建立稳定的连接。只有这样的log没有任何报错信息。

请问:
1/ 是这个镜像中的vnpy版本已经过期了吗?还是我的设置哪里出现了问题?
2/ 参考了入门教程,似乎有的vnpy版本不能连接simnow。如果我要使用vnpy来访问simnow,目前推荐使用的稳定版本是?

万分感谢!

Administrator
avatar
加入于:
帖子: 2453
声望: 103

这个docker镜像的版本太老了,现在需要CTP穿透式版本,这个镜像里的CTP API已经无法使用

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3