vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 9
声望: 0

vnstudio-2.0.8.exe
win10 下安装失败。

失败提示:

安装程序错误

安装过程中出现错误(dependents)

执行失败(意外退出代码:1):“E:\vnstudio/python.exe -m pip install --no-index -f E:\vnstudio/pkgs -r E:\vnstudio/pkgs/requirements.txt”

Retry Ignore Cancel

好像是 安装 requirements.txt line14 的时候出现。

Administrator
avatar
加入于:
帖子: 2453
声望: 103

这个一般是某个系统级别的DLL库被重新定向导致的,换个机器试试吧

Member
avatar
加入于:
帖子: 9
声望: 0

终于装好。可能需要在科学上网情况下,安装。

Member
avatar
加入于:
帖子: 9
声望: 0

新版本界面确实美观,柔和很多。

Administrator
avatar
加入于:
帖子: 2453
声望: 103

微雨燕双飞 wrote:

终于装好。可能需要在科学上网情况下,安装。

感谢夸奖哈,请问下用的是什么科学上网方式呢?VPN、Shadowsocks全局代理?

Member
avatar
加入于:
帖子: 9
声望: 0

用Python的交易员 wrote:

微雨燕双飞 wrote:

终于装好。可能需要在科学上网情况下,安装。

感谢夸奖哈,请问下用的是什么科学上网方式呢?VPN、Shadowsocks全局代理?

感谢大神回复。

我用的VPN呢。
win10 64位,用的手动安装的方式。
我下载的最新版 Anaconda3-2019.10-Windows-x86_64.exe

碰到的问题如下:

问题 1 . pip 安装 提示 ssl 无效之类。
网上有不少解决方案,要重新下载,编译之类的, 都比较麻烦。
其中一个方法我觉得较简洁, 指定path 路径为 :X:\ProgramData\Anaconda3\Library\bin

问题 2 碰到的情况是,QT版本冲突。

安装过程中提示 spider3.7 QT版本不兼容,安装不成功。
后来把 spider 升级到 4.0 .还是提示QT不兼容,不过可以安装成功。
VNPY 能用 。spider用不了。

分享我的安装过程出来,希望对后来者有帮助。

Administrator
avatar
加入于:
帖子: 2453
声望: 103

非常感谢分享。看来一个是SSL,一个是QT,两个DLL都被重新定向了路径

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3