vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 9
声望: 0

尝试在树莓派上安装vnpy2.0.7,踩过了N多坑之后,最后卡在了vnpy的编译上,报错信息如下:
running build_ext
building 'vnpy.api.ctp.vnctptd' extension
arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -Ivnpy/api/ctp/include -Ivnpy/api/ctp/vnctp -I/usr/include/python3.7m -c vnpy/api/ctp/vnctp/vnctptd/vnctptd.cpp -o build/temp.linux-armv7l-3.7/vnpy/api/ctp/vnctp/vnctptd/vnctptd.o -std=c++17 -O3 -Wno-delete-incomplete -Wno-sign-compare
arm-linux-gnueabihf-gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,relro -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 build/temp.linux-armv7l-3.7/vnpy/api/ctp/vnctp/vnctptd/vnctptd.o -Lvnpy/api/ctp/libs -Lvnpy/api/ctp -Wl,--enable-new-dtags,-R$ORIGIN -lthostmduserapi_se -lthosttraderapi_se -o build/lib.linux-armv7l-3.7/vnpy/api/ctp/vnctptd.cpython-37m-arm-linux-gnueabihf.so -lstdc++
vnpy/api/ctp/libthostmduserapi_se.so: file not recognized: file format not recognized
collect2: error: ld returned 1 exit status
error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1

我理解这个libthostmduserapi_se.so,是在不同的平台上用不同的gcc版本编译的,在树莓派上无法识别?
请教下@用Python的交易员,vnpy是否可以在arm平台上安装成功运行?
盼复,多谢!

Administrator
avatar
加入于:
帖子: 4033
声望: 222

请不要浪费时间在树莓派这种玩具平台上跑量化交易的程序,另外大部分原生API也都不支持ARM的处理器

Member
avatar
加入于:
帖子: 9
声望: 0

好的,谢谢!

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3