vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 12
声望: 0

官方推荐的anaconda=5.2.0,我安装anaconda 5.2.0 后,再安装官方推荐的 ta-lib =0.4.9结果最后出现下面冲突。

C:\Users\sh>conda install -c quantopian ta-lib
Solving environment: failed

UnsatisfiableError: The following specifications were found to be in conflict:

  • anaconda=5.2.0 -> mkl-service==1.1.2=py27h9f02974_4
  • anaconda=5.2.0 -> numexpr==2.6.5=py27h3b259a0_0
  • anaconda=5.2.0 -> scikit-learn==0.19.1=py27h0778779_0
  • anaconda=5.2.0 -> sqlite==3.23.1=h0f31022_0
  • ta-lib
    Use "conda info <package>" to see the dependencies for each package.

我在github上看到以前有人提到这个问题,都是安装anaconda=4.0.0,但是现在官方不是说安装anaconda=5.2.0么,怎么还是冲突了

Administrator
avatar
加入于:
帖子: 2096
声望: 96

https://www.lfd.uci.edu/~gohlke/pythonlibs/

5.2.0的请下载这里的talib的wheel安装包后安装

Member
avatar
加入于:
帖子: 12
声望: 0

用Python的交易员 wrote:

https://www.lfd.uci.edu/~gohlke/pythonlibs/

5.2.0的请下载这里的talib的wheel安装包后安装

哪个版本的ta-lib,还是最新的即可

Administrator
avatar
加入于:
帖子: 2096
声望: 96

这里talib只有一个版本,选和你的Python对应的安装包就行

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3