vn.py量化社区
By Traders, For Traders.
Member
加入于:
帖子: 77
声望: 17

我使用VNPY 1.9.2版本,因为监管要求,需要支持看穿式终端,这里说说实现流程。2.0版本还没有试过,不太确定,仅做参考。

首先感谢vnpy及时更新。

可以去GITHUB https://github.com/vnpy/vnpy/tree/v1.9.2-LTS , 下载最新版本。

第一步是和期货公司客户经理联系,一般他会给你一个申请表,填号信息,主要是AppID:client_vnpyXXXX_版本号,这里都是自开发系统,所以可以随便填。然后会收到一个确认邮件,包括测试服务器地址,和终端认证码(AuthCode)。

第二步是更新vnpy到最新版本;两种更新方法:

  1. 是pip uninstall vnpy, 然后重装最新版本;

  2. 如果自开发比较多,可以试着手动更新;更新文件夹是anacoda的lib里面的vnpy/api/ctp,和vnpy/trader/gateway/ctpGateway 和ctptestGateway,其中ctptestGateway是支持6.3.13,用于登陆评测系统;ctpGateway 是6.3.15接口,正式使用。

第三步,更新登陆信息,登陆测试系统。

1.更新examples\VnTrader\CTPTEST_connect.json,填入测试服务器的地址,AppID和终端认证码(AuthCode);用户密码。

  1. 修改examples\VnTrader\run.py, 改为加载测试接口。

    # 加载底层接口
     from vnpy.trader.gateway import (ctptestGateway, ibGateway, huobiGateway)
     #from vnpy.trader.gateway import (ctpGateway, ibGateway, huobiGateway)
     # 添加交易接口
     #me.addGateway(ctpGateway)
     me.addGateway(ctptestGateway)

    3.运行VnTrader.bat, 登陆系统,可以尝试下单。

第四步,如果正式启用,用改回加载正式接口。

Member
avatar
加入于:
帖子: 13
声望: 0

很好,其实还有个问题,就是以后你自己交易时换成其他版本软件的话,只要能正常采集到信息应该也是没人管的吧?至少不能是换个机子就要期货公司认证一把吧?这样监管也真是神了,可还是免不了大家还是可以刷bios,确实不懂这样监管的目的何在。

Member
avatar
加入于:
帖子: 8
声望: 0

按照你的步骤通过了测试,但是改回加载ctp接口进入仿真环境时,显示已登录,但没有行情信息,但是期货公司显示可以行情信息正常,
这是为什么?

Member
avatar
加入于:
帖子: 20
声望: 0

这个太好,目前我使用181版本实盘。代码方面,我只需要同步一下192lts版本修改处就好了。不用再费时间在ctp 3.15版本上了。感谢。

Member
加入于:
帖子: 19
声望: 1

看了前面的回答,想问下,看穿式监管是不能换机器的吗?

Member
加入于:
帖子: 77
声望: 17

luffyasce wrote:

看了前面的回答,想问下,看穿式监管是不能换机器的吗?

我也有这个疑问,我是在本地开发机做的测试,但是交易在云生产环境。问了期货的技术人员,也没确定答复,只是叫我最好在生产机也做一次

Member
加入于:
帖子: 77
声望: 17

roger wrote:

按照你的步骤通过了测试,但是改回加载ctp接口进入仿真环境时,显示已登录,但没有行情信息,但是期货公司显示可以行情信息正常,
这是为什么?

不清楚,检查下td和md是否正确,另外之前碰到过一个vs code系统language问题,不知道你是不是这个情况,

Member
加入于:
帖子: 77
声望: 17

张国平 wrote:

luffyasce wrote:

看了前面的回答,想问下,看穿式监管是不能换机器的吗?

我也有这个疑问,我是在本地开发机做的测试,但是交易在云生产环境。问了期货的技术人员,也没确定答复,只是叫我最好在生产机也做一次

和技术人员确认了,是和机器无关,只是证明接口支持抓取本地信息。只要证明可以抓取就OK了

Member
加入于:
帖子: 19
声望: 1

张国平 wrote:

张国平 wrote:

luffyasce wrote:

看了前面的回答,想问下,看穿式监管是不能换机器的吗?

我也有这个疑问,我是在本地开发机做的测试,但是交易在云生产环境。问了期货的技术人员,也没确定答复,只是叫我最好在生产机也做一次

和技术人员确认了,是和机器无关,只是证明接口支持抓取本地信息。只要证明可以抓取就OK了
谢谢兄弟

Member
avatar
加入于:
帖子: 91
声望: 2

好贴,应该置顶。

Member
avatar
加入于:
帖子: 20
声望: 0

192LTS版本的ctptestGateway用的是自身目录下的vnctpmd.pyd和vnctptd.pyd文件,这两个文件都是最近新生成的,不应该用旧版本库文件吗?

Member
avatar
加入于:
帖子: 20
声望: 0

Z侠 wrote:

192LTS版本的ctptestGateway用的是自身目录下的vnctpmd.pyd和vnctptd.pyd文件,这两个文件都是最近新生成的,不应该用旧版本库文件吗?
是我弄错了,ctptestGateway也是穿透式监管评测版本,对应的front_se前端为6.3.13版本。

Member
加入于:
帖子: 19
声望: 1

还有个问题,vnpy更新版本会影响穿透式监管吗?比如现在我用vnpy 2.0.3 测试接入期货公司,以后实盘改用vnpy 2.0.5这样。@vnpy作者

Administrator
avatar
加入于:
帖子: 1690
声望: 80

luffyasce wrote:

还有个问题,vnpy更新版本会影响穿透式监管吗?比如现在我用vnpy 2.0.3 测试接入期货公司,以后实盘改用vnpy 2.0.5这样。@vnpy作者

不会,后续版本都会是穿透式版本的API

Member
加入于:
帖子: 19
声望: 1

用Python的交易员 wrote:

luffyasce wrote:

还有个问题,vnpy更新版本会影响穿透式监管吗?比如现在我用vnpy 2.0.3 测试接入期货公司,以后实盘改用vnpy 2.0.5这样。@vnpy作者

不会,后续版本都会是穿透式版本的API

好的,谢谢

Member
avatar
加入于:
帖子: 11
声望: 0

用的1.9.2版本,在该目录下没有找到ctptestGateway???

Member
avatar
加入于:
帖子: 20
声望: 0

miluoweiqi wrote:

用的1.9.2版本,在该目录下没有找到ctptestGateway???
192LTS版本

Member
avatar
加入于:
帖子: 27
声望: 0

vnpy:1.9.2版本
1、安装目录下的\vnpy\api\ctp 已经拷贝最新的1.9.2版本的文件夹了,不是覆盖的,是原来的改了名字,这个拷贝整个文件夹过来的

2、安装目录下的 \vnpy\trader\gateway\ctptestGateway 拷贝了ctptestGateway的整个文件夹的,另外也拷贝了ctpGateway最新的过来,老的是改了文件夹名字

3、修改了\examples\VnTrade 下的run里边,增加了
me.addGateway(ctptestGateway) # 测试
同时注释掉了ctpGateway的那行。同时加载了ctptestGateway模块的。

4、修改了文件CTPTEST_connect.json文件中的全部链接地址等信息,确定地址等信息都没错的,检查过多遍,并且都是拷贝过来的不是输入的。

报错是:交易服务器连接断开,我输入rb1912后,报错是接口不存在,是在是不知道哪里错误了,请了解这部分的大佬们给指点下是哪里弄得不对的了。
谢谢

Member
avatar
加入于:
帖子: 27
声望: 0

enter image description here

Member
加入于:
帖子: 77
声望: 17

禅悟 wrote:

enter image description here

我之前碰到过类似的问题,可能是放置jason文件utf-8编码,用text editor重新保存utf格式

© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3