vn.py量化社区
By Traders, For Traders.
Member
avatar
加入于:
帖子: 13
声望: 0

description

description
选的是cpttest 版本是studio 最新的2.1.7 .这边穿透的版本是 api版本 6.3.15

Member
avatar
加入于:
帖子: 13
声望: 0

求教

Member
avatar
加入于:
帖子: 959
声望: 51

请问是同时勾选了ctp和ctptest吗?

Member
avatar
加入于:
帖子: 13
声望: 0

下雨天 wrote:

求教
没有,我只选择了cptest

Member
avatar
加入于:
帖子: 13
声望: 0

xiaohe wrote:

请问是同时勾选了ctp和ctptest吗?
只选了ctptest

Member
avatar
加入于:
帖子: 959
声望: 51

如果没有输错账号密码,cmd运行有输出Decrypt handshake data failed的话,那应该就是api版本不匹配的问题了
可参考此帖的34楼

Member
avatar
加入于:
帖子: 13
声望: 0

很奇怪的是我选择了ctp和ctptest两个的时候,是可以的都顺利的通过。

Member
avatar
加入于:
帖子: 13
声望: 0

期货公司给的版本是 api版本 6.3.15 。我这个cpttest是6.3.16 ,是不是兼容呢

Member
avatar
加入于:
帖子: 959
声望: 51
  1. 要用实盘账户就勾选ctp,要进行穿透式测试就勾选ctptest, ctp和ctptest不能同时勾选,dll会冲突;
  2. 请参考我上一条发的帖子,检查一下行情前置/交易前置/授权码等字段是否填错了;
  3. 如果没有,请在cmd中用python -m vnstation打开vnstation,如果报错Decrypt handshake data failed的话,那应该就是api版本不匹配的问题了,原因帖子里34楼也有详细介绍
© 2015-2019 上海韦纳软件科技有限公司
备案服务号:沪ICP备18006526号-3